«

»

fév 24 2013

Imprimer ceci Article

Accéder à une application incompatible sur Google Play

Juste avant le téléchargement d’une application sur le Google Play, vous vous êtes peut-être déjà trouvés face à ce message : « Cette application n’est pas compatible avec votre périphérique ». Rien de plus frustrant!. Il existe pourtant une solution, fonctionnant aussi bien sur téléphone que sur tablette, mais qui nécessite d’avoir activé le mode root.

Applications Android sur Google Play non compatible Accéder à une application incompatible sur Google Play

Pourquoi les applications Google Play sont bloquées?

Les éditeurs peuvent restreindre leurs applications selon les performances matérielles de votre terminal Android, ceci pour obtenir une expérience optimale de l’application ou du jeu (éviter les Force Close et saccades), même si, dans la majorité des cas, le débridage ne posera pas de problèmes.

Une application incompatible sur Google Play? 1ère solution : modification manuelle du Build.prop

C’est lui qui, lors de la connexion au Google Play, donne les informations de votre terminal (version de votre système, marque et modèle, langue…). Téléchargez l’application Build Prop Editor, faites une sauvegarde du fichier (menu Create Backup) et remplacez les valeurs « ro.product.model=XXX » et « ro.product.manufacturer=YYY » par respectivement Nexus 4 et LGE car étant le dernier modèle phare de Google, il accédera à toutes les applications sans restrictions. Sauvegardez le fichier puis quittez l’application. Maintenant afin d’effacer le cache, allez dans Paramètres, Applications, Gérer les applications, sur l’onglet Tout, sélectionnez Google Play Store et enfin Supprimer les données puis redémarrez votre périphérique.

Pourquoi faire compliqué quand on peut faire simple?

La procédure précédente étant un peu fastidieuse, Market Helper est apparu. Les avantages :

  • Pas de prise de risque, l’application se charge de la modification en 2 étapes simples :
Market Helper – spoof your Android device to download incompatible apps step1 Accéder à une application incompatible sur Google Play

Market Helper – Etape 1 : Choix du terminal que l’on veut emuler [P] pour smartPhone ou [T] pour tablette

Market Helper – spoof your Android device to download incompatible apps step2 Accéder à une application incompatible sur Google Play

Market Helper – Etape 2 : Se rendre sur Google Dashboard (une simple visite de page suffit)

  • Prise en charge immédiate (pas de reboot nécessaire)
  • Pour revenir en arrière, il suffit de redémarrer pour annuler les modifications (ou d’utiliser le menu Restore)

Je ne peux malheureusement pas tester cette appli car elle nécessite minumun Android 2.3+ et mon téléphone date un peu…vivement l’arrivée de mon Nexus 4

L’éditeur dit encore travailler sur Market Helper, pour cette fois, supprimer la restriction d’applications selon les pays. (en attendant, si vous êtes intéressés, vous avez la solution ici)

Source + Source

Lien Permanent pour cet article : http://sebastien.toursel.fr/android/application-incompatible-sur-google-play/

79 comments

Passer au formulaire de commentaire

  1. biboupqt45

    Trop dur les équations pour vérifier que nous sommes pas un robot 4 + … = 6 ?????

    1. admin

      Il est facilement possible de compliquer ces opérations (par remplacement ou/et combinaisons supplémentaires de : lettres(quatre+….=six), soustraction, multiplication…), mais ce n’est pas le but! Je sais que c’est déjà assez chiant de mettre un commentaire (merci au passage ;-)), si en plus on doit faire un calcul de dingue, plus personne n’en publiera! En fait, depuis la mise en place de l’outil de vérification, je n’ai plus reçu 1 seul commentaire de robots et c’est exactement le résultat que j’attendais!

      1. admin

        Ils sont forts ses robots lol….j’ai du (légèrement) renforcer la politique de sécurité Capcha : Les robots, bloqués jusqu’à présent, réussissaient désormais à passer (Ils étaient néanmoins mis en quarantaine car détectés indésirables par Akismet)

  2. spada michael

    J’ai testé cette application et ça marche, mais j ai un gros problème: lorsque l’appli se télécharge il y a un message d erreur : ABI de l’UC incompatible.
    Quelqu’un aurait une solution svp ?

    1. admin

      Vérifiez les pré-requis de l’application : Android 2.3 minimum et le mode ROOT activé.
      Vous pouvez réessayer ensuite avec cette version : http://codekiem.com/market-helper/latest

  3. spada michael

    Comment voir la version de l’application ?
    (j’ai un galaxy ace et je cherche à télécharger minecraft pour être plus precis)

    1. admin

      Si vous parlez des pré-requis nécessaires à une application ou un jeu : cela est spécifié dans la colonne de droite sur https://play.google.com/store/apps. Sinon dans Google Play, dans la partie « Développeur », vous pouvez accéder au site du développeur ou lui envoyer un mail.

  4. try again

    comment savoir si le mode root est activé ?

    1. admin

      Vous pouvez installer l’application RootChecker (https://play.google.com/store/apps/details?id=com.joeykrim.rootcheck&hl=fr) qui permet de vérifier facilement si votre terminal est rooté

      1. try again

        Merci gràce a ton lien je peux voir que mon tel est rooter. Mais je n’arrive toujours pas a télécharger et ma version de départ est android 2.3+ et maintenant c’est 4.1.1.

  5. try again

    moi çà me donne toujours abi de l’uc incompatible et pourtant je suis sous la rom jelly blast

    1. admin

      J’ai lu sur le site de l’application (http://codekiem.com/2013/02/13/market-helper/) qu’une personne a exactement le même problème. Elle a posé la question il y a un mois au développeur : on lui a répondu que cela venait de son téléphone : c’est tout simplement parce qu’il pas compatible (problème hardware)

  6. try again

    est ce que je peux rendre mon appareil compatible ? parce que sur le site même traduit en Français les commentaires sont en Anglais. please help me !

    1. admin

      Je crains que non! Malheureusement, la seule solution est de changer de téléphone (pas d’autres possibilités évoquées sur le site)
      Le Samsung Galaxy S4 vient de sortir, c’est l’occasion de se faire plaisir!

  7. try again

    J’ai un galaxy ace GT-S5839i de base et la c’est s5830i.

  8. try again

    Merci quand même de ton aide.

  9. try again

    mais j’espere me tromper dans l’installation.

  10. Paulo

    Peut-on lier une application au Play Store pour avoir les mises à jour quand on ne l’a pas installée avec ?

    1. admin

      Google veut absolument que toutes applications et mises à jour passent par le Play Store, donc les installations manuelles (depuis un APK) ne seront pas intégrés au compte Google associé.
      A ma connaissance, la seule solution (manuelle) est d’exécuter la nouvelle version de l’APK qui va écraser la précédente.

  11. couiby

    J’ai une tablette arnova10G2 et je n’arrive pas à telecharger les jeux

    1. admin

      Il semblerait que pour les tablettes Arnova il faut utiliser Arctools, à installer depuis Applibs (Source : http://forum.frandroid.com/topic/82662-arnova-10g2-et-android-market). Puisque vous êtes possesseur d’une tablette de cette marque, je vous invite également à consulter ce site : http://www.arctablet.com/blog/category/devices/arnova/arnova-g2/arnova-10-g2/?lang=fr

  12. ANdroid

    Depuis que j’ai fait la 1ère méthode, quand j’essaye d’accéder au Playstore ça me met « Aucune connexion » alors que je suis en wifi avec trois barres et sinon quand je suis en 3G et qu’il ça ma met ça aussi!
    Pourquoi?

    1. admin

      Dans le Build.prop, vérifiez que vous avec bien « ro.product.model=Nexus 4″ et « ro.product.manufacturer=LGE » ensuite effacez le cache (comme expliqué ci-dessus) et redémarrez votre téléphone

  13. ANdroid

    J’ai mis Nexus 4 à la place de LG-P500 et LGE ça y était déjà, j’ai effacé le cache et redémarré mon téléphone et…. Ca marche pas Que faire?

    1. admin

      Vous pouvez essayer avec un autre modèle de smarphone, comme le Nexus S :
      ro.product.model = Nexus S
      ro.product.manufacturer = samsung

  14. Goross Boll

    Alors j’ai un petit problème, j’ai fait toutes les procédures et à la fin je reboot mon téléphone le logo samsung s’affiche après plus rien, j’ai essayé le mode recovery çà n’a rien donné Help !!

    1. admin

      Il semblerait que ce soit lié à un problème de permissions, pour corriger le problème, vous pouvez consulter cet article : « Guide to fixing a soft brick after editing build.prop » à l’adresse http://forum.xda-developers.com/showthread.php?t=1927198

  15. eljoven

    Build.prop ne fonctionne pas sur mon galaxy nexus quand je lance le back up au début il me dit opération failed et quand je veux sauvegarder après avoir fait le changement il me dit failed saving

    1. admin

      Il semble que cela vienne de votre téléphone qui n’est pas rooté. De ce fait, l’application ne peut accéder à ce fichier système pour en faire une sauvegarde.

  16. Alexis

    Bonjour J’ai fait la manipulation et ça me dit : cet article n’est pas disponible dans votre pays
    Il n’y a pas un endroit où l’on peut modifier le pays ???

    1. Alexis

      Petit précision
      J’habite en Guadeloupe
      Peut-on faire croire au téléphone qu’on se trouve dans un pays où l’application est disponible ???

      1. admin

        Bonjour, Google détermine votre pays d’après les informations fournies par votre opérateur.
        Toujours en accès root, vous pouvez installer Market Enabler (http://me.rac.su) qui propose de changer d’opérateur téléphonique (virtuellement) depuis Settings List.
        Une liste [Pays] Operateur vous sera proposée. Par exemple, pour télécharger Netflix, une application normalement réservée aux utilisateurs américains, sélectionnez [US] T-mobile.

  17. thibaut

    j’ai essayé la deuxième méthode et quand j’appuie sur activé il me met « this device rooted. I will add support to unrooted devices in later versions » comment ça se fait ?

    1. admin

      Cela vient du fait que votre téléphone n’est pas rooté, pour l’instant l’application ne prend pas en charge les téléphones qui ne le sont pas.

      1. thibaut

        non mais c’est une tablette que j’ai

        1. admin

          Quand je dis « votre téléphone n’est pas rooté », cela veut dire que votre système Android n’est pas rooté, peu importe le matériel que vous utilisez (smartphone, tablette…).

  18. thibaut

    pouvez vous m’aider svp ?

    1. admin

      Essayez de rooter votre tablette via la méthode citée au début de l’article, sinon suivez ce lien pour une liste des tutoriaux de Root Android : http://www.androidpit.fr/fr/android/forum/thread/551879/Liste-des-tutoriels-de-root-Android-disponibles

  19. LeBigLoser

    J’essaye de télécharger une app mais ça me dit : ABI de l’UC incompatible je sais pas quoi faire (je ne veux pas supprimer ma ROM)

    1. admin

      Effectivement cela peut provenir de la ROM installée : Il faut vérifier qu’elle soit au moins en 2.3 et que le root soit activé. Assurez vous aussi d’obtenir la dernière version de Market Helper. Si vous avez vérifié ces points et que cela ne fonctionne toujours pas, il est possible que cela vienne du téléphone. (Voir commentaires précédents)

  20. zak

    que doi je faire apres choisir RO. PRODUCT.MODE
    STP

    1. admin

      Si vous parler de ro.product.model, il faut entrer Nexus 4

  21. nicoom98

    J’ai téléchargé l’appli sur mon android et rooté en version 2.3.6 mais après avoir téléchargé et installé un jeu quand je le lance ça me met l’application s’est arretée. Que dois-je faire ?

    1. admin

      Essayez une à une ces différentes actions depuis le menu Paramètres > Application, sélectionnez l’application puis :
      – « Forcer l’arret de l’application »
      – « Supprimez le cache » de l’application ou installez le logiciel Clean Master : https://play.google.com/store/apps/details?id=com.cleanmaster.mguard&hl=fr
      – « Effacer les données » (Supprimer les données liées à l’application)
      – « Désinstaller », réinstaller ensuite l’application (si vous téléchargez l’application ailleurs que sur le Google Play, re-téléchargez-la).
      Si le problème persiste, redémarrez votre téléphone / tablette.

  22. Arthur

    Bonjour, je cherche a installer l’application suivante : https://play.google.com/store/apps/details?id=com.noodlecake.pumpedbmxfree&hl=fr
    Mais il y a un message « Cette application n’est compatible avec aucun de vos appareils » … Je suis avec un samsung galaxy ace et quand je change le « ro.product model » et l’autre puis que je rallume mon telephone, les modifications ne restent pas … pouvez vous m’aider svp

    1. admin

      Bonsoir,
      C’est effectivement un problème qui peut parfois apparaitre sur certaines ROMS. Pourriez-vous également modifier le build.prop dans system/bin? N’oubliez pas de faire une sauvegarde au cas où
      Source : http://forum.xda-developers.com/showthread.php?t=2077438.

      1. Arthur

        je le modifie par quoi ? (merci de votre reponse ! :p)

        1. Arthur

          A oui et ou se trouve systeme/bin ? svp

        2. admin

          Ah quand même un merci!
          En fait, il faut aller via un explorateur de fichier activer le mode Root (c’est expliqué dans le point 1 du paragraphe « Comment activer OK Google: Pré-erquis et configuration » de l’article : http://sebastien.toursel.fr/android/activer-ok-google-sur-google-now-nexus-5).
          Ensuite naviguez dans le répertoire system puis bin et vous trouverez le build.prop à éditer.
          A vous de jouer!

          1. Arthur

            Je me suis rendu compte que mon appareil n’est pas rooté … je le fait a l’aide de superoneclick ? comme expliqué ici : http://sebastien.toursel.fr/android/rooter-android-smartphone
            mais le lien mis pour le telechargement est apparement malveillant me dit google … Ou puis-je le telecharger sinon ? :p

          2. admin

            Oui, vous pouvez le télécharger sans crainte!

  23. Choupette

    ça va faire plus de 2h que j’y uis que j’essaie indéfiniment de rendre compatible mon Galaxy ace avec par exemple Minion rush ou Subway Surfer mais je n’y arrive pas j’ai répété à plusieurs reprises la 1°technique et j’ai téléchargé Market Helper mais rien ne change.. et dans Build Prop Editor les modifications ne restent pas une fois que je rallume le téléphone.. Help me svp

  24. Choupette

    j’ai téléchargé root checker pour voir si mon téléphone était rooté, mais l’application m’a indiqué lorsque j’ai fait « verify root » que je n’avait pas de root acces.. Est ce que je peux quand meme rendre des jeux compatibles sans le mode ROOT ? Aidez-moi svp

    1. admin

      Bonsoir,

      C’est effectivement la cause du problème, il faut avoit rooté votre smartphone pour éditer le build.prop.
      Vous pouvez cependant y parvenir en consultant mon article (http://sebastien.toursel.fr/android/rooter-android-smartphone) ou celui-ci (http://www.tutoriels-android.com/2012/09/rooter-un-samsung-galaxy-ace.html), spécialement dédié pour votre Samsung Galaxy ACE.

  25. marie

    pour la première solution faut mettre nexus 4″ et LGE dans la même case ?

    1. marie

      alors

      1. admin

        Hé, on se calme, c’est pas écrit dépannage informatique et la politesse çà ne fait de mal à personne!
        Il faut modifier ces deux entrées dans le fichier build.prop :
        ro.product.model=Nexus 4
        ro.product.manufacturer=LGE

        1. Arthur

          Hey salut, quand je change « ro.product.model » par « ro.product.model=Nexus 4″ dans « PROPERTY NAME » (je ne modifie pas « PROPERTY VALUE » ou il est inscrit « GT-S5839i »), il me demande de redémarer le téléphone, (ce que je fait) et quand je retourne dans ce même endroit, il y est marqué : dans « PROPERTY NAME » : « ro.product.model » et dans « PROPERTY VALUE » : « Nexus 4=GT-S5839i » … Que faire s’il vous plait ? :p

          1. admin

            Salut!

            En fait, il faut modifier les deux valeurs avec Build Prop Editor:
            ro.product.model et ro.product.manufacturer

            Voici une capture d’écran de ces deux valeurs à modifier (Utilisez Nexus 4 ou Nexus 5, peu importe): http://goo.gl/DesW0a

        2. Arthur

          J’ai changé comme sur la capture d’écran, mais cela ne fonctionne toujours pas, que faire ?? (merci de votre aide malgrè mes difficultés ! :p )

          1. admin

            Pas de problème! Si vous avez modifié les deux valeurs avec l’application Build Prop Editor, vérifiez après le redémarrage qu’elles ont bien été enregistrées et n’oubliez pas de supprimer le cache.
            Comme précisé dans l’article, il faut être root (Testez avec Root Checker)

        3. Arthur

          Bon, j’ai testé avec Root checker qui m’a dit que c’était bon, j’ai effacé le cache mais toujours le même message « votre appareil n’est pas compatible avec cette version. » …
          Que faire de plus ?

          1. admin

            Quelle est la version Android ? et quelle est l’application?

        4. Arthur

          2.3.6
          Et il me faudrait « Pumped bmx free »

          1. Arthur

            Avez vous trouvé une solution ? :p

          2. admin

            Il faudrait envoyer un email au développeur depuis la page de l’application https://play.google.com/store/apps/details?id=com.noodlecake.pumpedbmxfree. Ceci afin de connaitre les prérequis : Version Android et configuration hardware spécifique, le cas échéant.

        5. Arthur

          Alors, après bientot 4-5 h de recherche sur le web (rien que ce soir), il n’y a plus le message « aplication incompatible » , je peut télécharger l’aplication mais a la fin, il me dit : « ABI de l’UC incompatible » … nouveau probleme ??

          1. admin

            Le message « ABI de l’UC incompatible » a déjà été évoqué dans les commentaires précédents de cet article : Il s’agit d’un problème de compatibilité matérielle avec le téléphone.

          2. Arthur

            Bon ben tant pis, et merci pour toutes vos réponses (aide)

  26. marie

    Merci !

    1. Arthur

      Moi cela ne fonctionne toujours pas, as tu fait quelque chose de spécial ?

  27. marie

    moi non

  28. Alex

    Bonjour, alors voilà j’ai télécharger l’application Market Helper mais je ne l’a retrouve pas dans mes applications, je l’ai cherché partout, pourtant quand je retourne dans le google play store ca me met bien que j’ai l’app…

    1. admin

      Bonsoir,
      Depuis votre téléphone, ouvrez le Play Store > Mes applications, sélectionnez l’application Market Helper puis Ouvrir. Essayez de redémarrer votre smartphone.
      N’oubliez pas que pour utiliser Market Helper, il faut être root.

      1. dynamos

        Bonjour,

        Je n’ai pas la case « ouvrir »
        Mon phone est un OnePlus One rooté

  29. Choupette

    Re,
    Je suis allée sur vos liens pr rooter mon tel mais je n’ai pas reussi. J’ai pourtant telechargé les fichiers « SuperOneClick » comme vous avez dit dans vos tutos mais je n’arrive pas à les ouvrir avec mon tel et dans root checker ca me met toujours que mon tel n’est pas rooté… Y a t-il une solution à mes problèmes ?

    1. admin

      Il y a toujours des solutions aux problèmes!
      Avez-vous essayé de rooter votre smartphone avec TowelRoot ?
      http://sebastien.toursel.fr/android/towelroot-root-android-galaxy-s5-compris/

  30. Djeazon

    Bonjour,

    J’ai un samsung galaxy y et j’aimerai installé 6play mais cette appli n’est pas compatible.
    J’ai installé build prop et j’ai mis create backup et il dit operation failed, ça veut dire quoi ?

    Merci

    1. admin

      Bonsoir,

      Cela signifie qu’il n’a pas été capable de créer le backup du build.prop.
      Est ce que votre téléphone est rooté? C’est un pré-requis.

      Si c’est bien le cas, vous pouvez sauvegarder le build.prop manuellement.
      Pour cela, tout d’abord, téléchargez le gestionnaire de fichiers Android ES File Explorer (http://goo.gl/Ii2JRL)
      Une fois dans ES File Explorer, allez sur Accès rapide (haut à gauche) et activez Explorateur Root (Acceptez si SuperSU vous demande)
      En haut à droite, choisissez « / » puis System, copier le fichier build.prop et renommez le en build.prop.bak par exemple afin d’avoir une copie de sauvegarde.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *


8 − = null

Vous pouvez utiliser les balises HTML suivantes : <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>